[v2,2/2] build: fix visibility of deprecated symbols

Message ID 1518062407-26798-3-git-send-email-odpbot@yandex.ru
State New
Headers show
Series
  • configure: enable all Automake warnings and make them errors
Related show

Commit Message

Github ODP bot Feb. 8, 2018, 4 a.m.
From: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>


Correct visibility regexp to allow symbols like _deprecated_odp_*.

Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>

---
/** Email created from pull request 460 (lumag:build-fixes)
 ** https://github.com/Linaro/odp/pull/460
 ** Patch: https://github.com/Linaro/odp/pull/460.patch
 ** Base sha: 257b08b35ceea41bad5a7f1c626496cf111e657a
 ** Merge commit sha: a42e90d8f0b66fad7224dc2acd7f696e4fb67bef
 **/
 platform/Makefile.inc | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Patch

diff --git a/platform/Makefile.inc b/platform/Makefile.inc
index a39cf69bb..bb23a4cb4 100644
--- a/platform/Makefile.inc
+++ b/platform/Makefile.inc
@@ -9,9 +9,9 @@  lib_LTLIBRARIES = $(LIB)/libodp-linux.la
 AM_LDFLAGS = -version-number '$(ODP_LIBSO_VERSION)'
 
 if ODP_ABI_COMPAT
-AM_LDFLAGS += -export-symbols-regex '^(_deprecated)?odp_'
+AM_LDFLAGS += -export-symbols-regex '^(_deprecated_)?odp_'
 else
-AM_LDFLAGS += -export-symbols-regex '^(_deprecated)?_?odp_'
+AM_LDFLAGS += -export-symbols-regex '^(_deprecated_)?_?odp_'
 endif
 
 AM_CFLAGS = "-DGIT_HASH=$(VERSION)"